Status
Back
Maintenance
iWallet app new release
Completed 7 Feb at 04:24am PST.
Affected services
app.iwallet.com
Completed
Maintenance completed
Posted 7 Feb at 04:24am PST.
Started
Updating backend server with the new release
Posted 7 Feb at 04:19am PST.